Problem #1
Symptom:
While building links, a blank screen is shown after selecting "License Pool" and clicking the create links button.
Cause:
The school does not have a LabSim License Pool set up on the LabSim Account.
Resolution:
Add a License Pool for products that this school will use.
Problem #2
Symptom:
EduApp wouldn’t load a course outline when working with licenses
Cause:
There is not a 1:1 radio between licenses and products.
When a single license contained multiple products, though the license was technically configured correctly, the EduApp would not load the course outline. The course outline would only load when the LabSim product was within a license without any other product titles.
Resolution:
Fix or create a License Pool for only one product.
Problem #3
Symptom:
When you click the EduApp tool in the left navigation to build links, the screen has the following error:
"While(1);{"error":"invalid_client","error_description":"unknown client"}
Cause:
The most-likely problem is the Canvas Dev Key or ID:
It has not been created in the canvas environment
It has been created, but not sent to TestOut via the secure form
It has been created, but sent incorrectly to TestOut via the secure form
Resolution:
See if Canvas Key/ID are in the LabSim School screens
Have client confirm/share the Canvas Dev Key/ID values and compare what is in the LabSim screens
Delete current values in LabSim, and have client recreate/reshare Dev Key/ID via the secure form
Problem #4
Symptom:
When you click the EduApp tool>select access keys or license> try to change the version of the product but the "Select different version" button does not show up.
Cause:
The most likely cause is the tool was designed to only have one version of the product in each canvas shell. Therefore, links have already been created in canvas and labsim using a version.
Resolution: Check the following:
The LabSim Admin has to check the product version in their LabSim account (most likely problem)
Go into canvas and labsim and delete all links and classes that associate the product to a version.
Problem #5
Symptom:
Blank white page while loading the EduApp
Cause:
The browser settings have the allow "third party cookies" turned off.
For a Chrome exceptions [*.]testout.com
Resolution:
Try a different browser or turn off "Third party cookies"… allow them to come. Yummy cookies!!!!
Problem #6
Symptom:
Problem where some students grades are not syncing into Canvas, though these same scores can be seen within LabSim, they just don't move over or sync into Canvas.
Cause:
Students with scores that are not syncing have duplicate LabSim accounts. This happens when students create their LabSim accounts from our site (www.testout.com) and use a different email address than what is associated with their Canvas account.
Resolution:
We have a prompt that comes up for students to merge their own accounts after clicking through from Canvas, but they both need the access key they used as well as the user and password.
Merge duplicate accounts. After doing this students that click assignments from Canvas shouldn't be a problem and your synchronize button attached to the EduApp should be able to synchronize their scores.
Going forward, students begin each term by going through Canvas links and not www.testout.com, it is likely that less like issues will occur.
Problem #7
Symptom:
When trying to run the TestOut EduApp this error is generated: "The resource you are looking for has been removed, had its name changed, or is temporarily unavailable"
…the error occurs when the admin clicks TestOut EduApp after enabling it within the Canvas course. The app is installed on the sub account level, and not on the course level.
Cause:
The user is running in Brave browser with a Shield functionality running.
Resolution:
The error no longer occurs after turning off the Shield functionality within the Brave browser.
Problem #8
Symptom:
“Object moved to here” error followed by “you don’t have permissions” error occurring when trying to use the TestOut EduApp.
Cause:
The school Canvas Admin has not edited necessary system URLs after the school has been migrated to LabSim 6.
Problem #9
Symptom:
“Unknown State"/”Invalid State” when starting up TestOut EduApp.
Cause:
Developer Key may be in the Off position.
Resolution:
Turn Developer Key to the On position.
Problem #10
Symptom:
"lti0Auth failed" error message is generated when trying to launch the TestOut EduApp in a Canvas course.
Cause:
Possibly a broken EduApp install.
Resolution:
Uninstall and reinstall the TestOut EduApp.
Problem #11
Symptom:
If you have noticed that you are missing a LabSim class on your LabSim dashboard (even if other classes are there) you may be asking, "How do I get my class in my LabSim dashboard?"
Cause:
If an expected class is not appearing in LabSim it may be that as the instructor you have not clicked on an initial LabSim assignment in your LMS course and crossed over into LabSim. When you click on an initial assignment and cross over into LabSim the name of your LMS course is used to create a like-named class in LabSim.
Resolution:
Try clicking on an assignment link from within your LMS course and then check to see if the missing class now appears on your LabSim dashboard/home page. Note: For each course you have in the LMS, you need to click on at least one assignment in that course to create the class in LabSim. For example, if you have 4 courses, go to each of the 4 courses, and click on at least one link from each course.
Problem #12
Symptom:
“Invalid Consumer key” error message is generated when trying to launch the TestOut EduApp in a Canvas course.
Cause:
Possibly two EduApp instances installed
Resolution:
View app configurations to verify there is only One app installed
Problem #13
Symptom:
The instructor is not seeing the class(es) in the Classes tab of LabSim AFTER clicking a link from the LMS over to LabSim, and you use "Canvas Cross-listing" to combine individual Canvas Courses into one Course.
Potential Cause:
The class may have been Archived when it was first created, and it is hidden in the Archived Classes view. By default, the classes shown after logging in are the Active Classes.
Resolution
To unarchive a class, click View > Archived Classes. For the archived class, click the More button, and select Unarchive Class.
Problem #14
Symptom:
If you try to run the TestOut EduApp an "Invalid or missing session for oauth" error message is generated.
Potential Cause:
The Canvas Security Token is corrupted or otherwise not updating.
Resolution
Delete the Canvas Security Token and try to run the TestOut EduApp within the Canvas course. This should allow the TestOut EduApp to authorize and run, thus generating a new security token.
Problem #15
Symptom:
If a student tries to access an assignment via the "Grades" tab, they will be taken to the "Assignment" tab. They will not be able to access the assignment on the "Assignment" tab. They will see a "No Preview Available" error.
Potential Cause:
Student is unfamiliar with how to navigate Canvas.
Resolution
Student will need to access the assignments via the "Modules" tab.